import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z_]+:[a-zA-Z_]+:[a-zA-Z_]+(?:;(?!$)|$))+$";
final String string = "a_b:bread:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
+ " ab:bread:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
+ "a_b:any other characters break it:stack_overflow;test:this_thing:jane;Get_me:h:down\n"
+ "a_b:bread:format_messed_up-test:this_thing:jane;Get_me:h:down\n"
+ "a_b:bread:stack_overflow;test:this_thing:jane;semi_colon_at_end;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}