#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=build\()\s*""(?<jobname>[^""]+)""(?:,\s*(?<paramname>\w+)\s*:\s*(?<paramvalue>\w+|"".+""))+"
Local $sString = "parallel" & @CRLF & _
"(" & @CRLF & _
"{" & @CRLF & _
" build( "job2", parameter3: value3, parameter4: value4, parameter5: value5 )" & @CRLF & _
" build( "job1", parameter1: value1, parameter2: value2 )" & @CRLF & _
")" & @CRLF & _
"}" & @CRLF & _
"parallel " & @CRLF & _
"(" & @CRLF & _
"{" & @CRLF & _
" build( "job3", parameter6: value6, parameter7: value7, parameter8: value8, parameter9: value9 )" & @CRLF & _
"}" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)" & @CRLF & _
"" & @CRLF & _
"build( "jobx", parameterx: valuex, parameterx: valuex, parameterx: valuex, parameterx: valuex )" & @CRLF & _
"" & @CRLF & _
"build( "jobxx", parameterxx: valuexx, parameterxx: valuexx, parameterx: valuex, parameterx: valuex )" & @CRLF & _
"" & @CRLF & _
"build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")