import Foundation
let pattern = #"(?<=build\()\s*""(?<jobname>[^""]+)""(?:,\s*(?<paramname>\w+)\s*:\s*(?<paramvalue>\w+|"".+""))+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
parallel
(
{
build( "job2", parameter3: value3, parameter4: value4, parameter5: value5 )
build( "job1", parameter1: value1, parameter2: value2 )
)
}
parallel
(
{
build( "job3", parameter6: value6, parameter7: value7, parameter8: value8, parameter9: value9 )
}
)
build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)
build( "jobx", parameterx: valuex, parameterx: valuex, parameterx: valuex, parameterx: valuex )
build( "jobxx", parameterxx: valuexx, parameterxx: valuexx, parameterx: valuex, parameterx: valuex )
build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)