use strict;
my $str = 'parallel
(
{
build( "job2", parameter3: value3, parameter4: value4, parameter5: value5 )
build( "job1", parameter1: value1, parameter2: value2 )
)
}
parallel
(
{
build( "job3", parameter6: value6, parameter7: value7, parameter8: value8, parameter9: value9 )
}
)
build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)
build( "jobx", parameterx: valuex, parameterx: valuex, parameterx: valuex, parameterx: valuex )
build( "jobxx", parameterxx: valuexx, parameterxx: valuexx, parameterx: valuex, parameterx: valuex )
build("jobxy", parameterxy: "https://abc-xyz.pqrs.com", parameterxy: valuexy, parameterxy: valuexy)';
my $regex = qr/(?<=build\()\s*""(?<jobname>[^""]+)""(?:,\s*(?<paramname>\w+)\s*:\s*(?<paramvalue>\w+|"".+""))+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}