package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.{2,}\s*(.+)$`)
var str = `VAL1. Val2................................ Deal value ($ Mil)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}