re = /\.{2,}\s*(.+)$/m
str = 'VAL1. Val2................................ Deal value ($ Mil)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end