$re = '/\.{2,}\s*(.+)$/m';
$str = 'VAL1. Val2................................ Deal value ($ Mil)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);