# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?://)?(www\.)?(\S+)(\.[^\s\/]+)(/\S*)?"
test_str = ("https://www.google.com\n"
"http://coreyms.com\n"
"https://www.youtube.com/watch?v=sa-TUpSx1JA\n"
"https://www.nasa.gov\n"
"www.desmos.com\n"
"pastebin.com/s8fh3HAs\n"
"https://www.regex101.com/\n"
"www.translate.google.com/\n"
"https://roblox.com/home\n"
"chat.openai.com/?model=text-davinci-002-render-sha\n"
"https://www.amazon.com/\n"
"agar.io/#ffa")
subst = "$3$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.