$re = '/^(help|support|int\.form)\.eset\.com$/mi';
$str = 'help.eset.com
support.eset.com
int.form.eset.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);