using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"M[^a-zA-Z]*?y[^a-zA-Z]*?M[^a-zA-Z]*?o[^a-zA-Z]*?m[^a-zA-Z]*?s[^a-zA-Z]*?h[^a-zA-Z]*?o[^a-zA-Z]*?u[^a-zA-Z]*?s[^a-zA-Z]*?e";
string input = @"text 123 ->My Mom's house<- jidjio""
""bla bla ->My8Mo2ms231#43house<- bla bla""
""Test string ->My Mom's' house<- further text"" etc.
""wkashhasMdykMomLsfheoousssswQseBswenksd""
""textMy?M?om*s?*hou?*seorsomethingelse";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}