# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"M[^a-zA-Z]*?y[^a-zA-Z]*?M[^a-zA-Z]*?o[^a-zA-Z]*?m[^a-zA-Z]*?s[^a-zA-Z]*?h[^a-zA-Z]*?o[^a-zA-Z]*?u[^a-zA-Z]*?s[^a-zA-Z]*?e"
test_str = ("text 123 ->My Mom's house<- jidjio\"\n"
"\"bla bla ->My8Mo2ms231#43house<- bla bla\"\n"
"\"Test string ->My Mom's' house<- further text\" etc.\n"
"\"wkashhasMdykMomLsfheoousssswQseBswenksd\"\n"
"\"textMy?M?om*s?*hou?*seorsomethingelse")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.