re = /M[^a-zA-Z]*?y[^a-zA-Z]*?M[^a-zA-Z]*?o[^a-zA-Z]*?m[^a-zA-Z]*?s[^a-zA-Z]*?h[^a-zA-Z]*?o[^a-zA-Z]*?u[^a-zA-Z]*?s[^a-zA-Z]*?e/m
str = 'text 123 ->My Mom\'s house<- jidjio"
"bla bla ->My8Mo2ms231#43house<- bla bla"
"Test string ->My Mom\'s\' house<- further text" etc.
"wkashhasMdykMomLsfheoousssswQseBswenksd"
"textMy?M?om*s?*hou?*seorsomethingelse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end