import re
regex = re.compile(r"(?<=:\s)\w+(?:-\w+)*(?: and \w+(?:-\w+)*)*", flags=re.MULTILINE)
test_str = ("Product: TLD-1433 infusion Therapy\n"
"Biological: CG0070|Other: n-dodecyl-B-D-maltoside\n"
"Drug: Atezolizumab\n"
"Drug: N-803 and BCG|Drug: N-803\n"
"Drug: Everolimus and Intravesical Gemcitabine\n"
"Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")