re = /(?<=:\s)\w+(?:-\w+)*(?: and \w+(?:-\w+)*)*/m
str = 'Product: TLD-1433 infusion Therapy
Biological: CG0070|Other: n-dodecyl-B-D-maltoside
Drug: Atezolizumab
Drug: N-803 and BCG|Drug: N-803
Drug: Everolimus and Intravesical Gemcitabine
Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end