$re = '/"\s*([^"]*?)\s*"/m';
$str = '... che si concluse con la " desegregazione " degli autobus.';
$subst = "\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;