import re
regex = re.compile(r"\"\s*([^\"]*?)\s*\"", flags=re.MULTILINE)
test_str = "... che si concluse con la \" desegregazione \" degli autobus."
subst = "\"$1\""
result = regex.sub(subst, test_str)
if result:
print(result)