re = /"\s*([^"]*?)\s*"/m
str = '... che si concluse con la " desegregazione " degli autobus.'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result