#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=::)[^:]+(?=\n|$)"
Local $sString = "ID::ID123" & @CRLF & _
"PUBLISHED_TWEET::ABC" & @CRLF & _
"DEF" & @CRLF & _
"GHI" & @CRLF & _
"EMPLOYEE_ID::ID234" & @CRLF & _
"TWEET::ABC" & @CRLF & _
"DEF" & @CRLF & _
"GHI" & @CRLF & _
"ID::ID345" & @CRLF & _
"TWEET::#@ABC" & @CRLF & _
"DEF" & @CRLF & _
"GHI@.[]" & @CRLF & _
"USER_IDD::ID456" & @CRLF & _
"TWEET::google.com" & @CRLF & _
"123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")