import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=::)[^:]+(?=\\n|$)";
final String string = "ID::ID123\n"
+ "PUBLISHED_TWEET::ABC\n"
+ "DEF\n"
+ "GHI\n"
+ "EMPLOYEE_ID::ID234\n"
+ "TWEET::ABC\n"
+ "DEF\n"
+ "GHI\n"
+ "ID::ID345\n"
+ "TWEET::#@ABC\n"
+ "DEF\n"
+ "GHI@.[]\n"
+ "USER_IDD::ID456\n"
+ "TWEET::google.com\n"
+ "123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}