import re
regex = re.compile(r"(?<=::)[^:]+(?=\n|$)", flags=re.MULTILINE)
test_str = ("ID::ID123\n"
"PUBLISHED_TWEET::ABC\n"
"DEF\n"
"GHI\n"
"EMPLOYEE_ID::ID234\n"
"TWEET::ABC\n"
"DEF\n"
"GHI\n"
"ID::ID345\n"
"TWEET::#@ABC\n"
"DEF\n"
"GHI@.[]\n"
"USER_IDD::ID456\n"
"TWEET::google.com\n"
"123456789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")