const regex = /\[m1\](\S+?)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[m1\\](\\S+?)\\s', 'gm')
const str = `[m1]word end
[m1]word
notbegin[m1]word
[m1]word
[m1] word
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}