re = /\[m1\](\S+?)\s/m
str = '[m1]word end
[m1]word
notbegin[m1]word
[m1]word
[m1] word
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end