$re = '/\[m1\](\S+?)\s/m';
$str = '[m1]word end
[m1]word
notbegin[m1]word
[m1]word
[m1] word
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);