import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?(?P<ref>[ACTG])>(?P<alt>[ACTG]))?";
final String string = "NM_12345.5:c.1999+500C>A\n"
+ "NR_12345.5:c.1999+500C>A\n"
+ "XM_12345.5:c.1999+500C>A\n"
+ "XR_12345.5:c.1999+500C>A\n"
+ "ENST12334455677:c.1999+500C>A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}