import re
regex = re.compile(r"(?P<reference_sequence>(NM|NR|XM|XR)_[0-9]{4,12}|ENST[0-9]{1,11})(\.(?P<version>([0-9]?[0-9])))?(:(?P<prefix>c|n)\.(?P<start>-?[1-9][0-9]{0,7})(?P<start_offset>[+-][1-9][0-9]{0,7})?(?P<ref>[ACTG])>(?P<alt>[ACTG]))?", flags=re.MULTILINE)
test_str = ("NM_12345.5:c.1999+500C>A\n"
"NR_12345.5:c.1999+500C>A\n"
"XM_12345.5:c.1999+500C>A\n"
"XR_12345.5:c.1999+500C>A\n"
"ENST12334455677:c.1999+500C>A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")