#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?si)(?<=<span style="font-size: 16px; font-family: Arial;">)(?!.*?(?:strong|contenuto)).*? <\/span><br>.*?(?=<\/span><br>\s+<br>)"
Local $sString = "<p data-mce-style="margin-top: 5.0pt; margin-right: 1.5pt; margin-bottom: 5.0pt; margin-left: 37.55pt; mso-pagination: widow-orphan;" style="margin: 5pt 1.5pt 5pt 37.55pt; text-align: center;"><br>" & @CRLF & _
"</p>" & @CRLF & _
"<p style="text-align: center;">" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;"><strong>Caratteristiche:</strong></span><br>" & @CRLF & _
"<br>" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;"> Contenuto del" & @CRLF & _
"pacco:</span><br>" & @CRLF & _
"<br>" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;">PC empire , usato perfettamente funzionante con windows 10 anche se ha coa windows 7 originale " & @CRLF & _
"con lettore di schede di memoria mmc e altri formati con 8 porte usb 2.00 , con processore i5 -2400 e 8gb di ram" & @CRLF & _
"500 gb di hardisk e lettore masterizzatore dvd scheda lan on board e scheda video e audio onboard " & @CRLF & _
"windows 10 64 bit appena installato , perfettamente funzionante </span><br>" & @CRLF & _
"<br>" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;"> " & @CRLF & _
"l'acquisto e' fatto come visto e piaciuto" & @CRLF & _
"le immagini descrivono i prodotti e le condizioni dei tali" & @CRLF & _
"le descrizioni dei prodotti sono puramente indicative. " & @CRLF & _
"Per ottenere una descrizione accurata si consiglia di visitare il sito del produttore." & @CRLF & _
"non rispondiamo di eventuali differenze riscontrabili tra le caratteristiche indicate nelle descrizioni e le immagini</span><br>" & @CRLF & _
"<br>" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;"> " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</span><br>" & @CRLF & _
"<br>" & @CRLF & _
"<span style="font-size: 16px; font-family: Arial;"><span style="color: rgb(255, 51, 51);"> </span><br>" & @CRLF & _
"</span> </p>" & @CRLF & _
"<p style="text-align: center;"><span style="font-size: 16px; font-family: Arial;"><br>" & @CRLF & _
"</span> </p>" & @CRLF & _
"<p style="text-align: center;"><span style="font-size: 16px; font-family: Arial;"><br>" & @CRLF & _
"</span> </p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")