# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?si)(?<=<span style=\"font-size: 16px; font-family: Arial;\">)(?!.*?(?:strong|contenuto)).*? <\/span><br>.*?(?=<\/span><br>\s+<br>)"
test_str = ("<p data-mce-style=\"margin-top: 5.0pt; margin-right: 1.5pt; margin-bottom: 5.0pt; margin-left: 37.55pt; mso-pagination: widow-orphan;\" style=\"margin: 5pt 1.5pt 5pt 37.55pt; text-align: center;\"><br>\n"
"</p>\n"
"<p style=\"text-align: center;\">\n"
"<span style=\"font-size: 16px; font-family: Arial;\"><strong>Caratteristiche:</strong></span><br>\n"
"<br>\n"
"<span style=\"font-size: 16px; font-family: Arial;\"> Contenuto del\n"
"pacco:</span><br>\n"
"<br>\n"
"<span style=\"font-size: 16px; font-family: Arial;\">PC empire , usato perfettamente funzionante con windows 10 anche se ha coa windows 7 originale \n"
"con lettore di schede di memoria mmc e altri formati con 8 porte usb 2.00 , con processore i5 -2400 e 8gb di ram\n"
"500 gb di hardisk e lettore masterizzatore dvd scheda lan on board e scheda video e audio onboard \n"
"windows 10 64 bit appena installato , perfettamente funzionante </span><br>\n"
"<br>\n"
"<span style=\"font-size: 16px; font-family: Arial;\"> \n"
"l'acquisto e' fatto come visto e piaciuto\n"
"le immagini descrivono i prodotti e le condizioni dei tali\n"
"le descrizioni dei prodotti sono puramente indicative. \n"
"Per ottenere una descrizione accurata si consiglia di visitare il sito del produttore.\n"
"non rispondiamo di eventuali differenze riscontrabili tra le caratteristiche indicate nelle descrizioni e le immagini</span><br>\n"
"<br>\n"
"<span style=\"font-size: 16px; font-family: Arial;\"> \n\n\n"
"</span><br>\n"
"<br>\n"
"<span style=\"font-size: 16px; font-family: Arial;\"><span style=\"color: rgb(255, 51, 51);\"> </span><br>\n"
"</span> </p>\n"
"<p style=\"text-align: center;\"><span style=\"font-size: 16px; font-family: Arial;\"><br>\n"
"</span> </p>\n"
"<p style=\"text-align: center;\"><span style=\"font-size: 16px; font-family: Arial;\"><br>\n"
"</span> </p>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.