using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_\d+";
string substitution = @"";
string input = @"4711_001.doc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}