const regex = new RegExp('_\\d+', 'gm')
const str = `4711_001.doc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);