package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_\d+`)
var str = `4711_001.doc`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}