package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\u0600-\u06FF\uFB8A\u067E\u0686\u06AF\u200C\u200F]+`)
var str = `سلام به تو ای زندهگی`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}