const regex = /[\u0600-\u06FF\uFB8A\u067E\u0686\u06AF\u200C\u200F]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u0600-\\u06FF\\uFB8A\\u067E\\u0686\\u06AF\\u200C\\u200F]+', 'gm')
const str = `سلام به تو ای زندهگی`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}