$re = '/[\u0600-\u06FF\uFB8A\u067E\u0686\u06AF\u200C\u200F]+/m';
$str = 'سلام به تو ای زندهگی';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);