const regex = /(?<=Attn:)(.*)(\d{8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Attn:)(.*)(\\d{8})', 'gm')
const str = `Restoration Coder: Mr. Vivek Patel 488.90 488.90
Attn: Mr. Matt Lomano (WO# 24107788)
0le Asphalt Repairs (Traffic ControltRemoval ofSpoilsfiSawcutting)
80 W est. Beaver Creek (Richmond Hill)
Restoration Coder: Mr. Vivek Patel 196.76 196.76
Attn: Mr. Matt. Lomano (WO# 23407489)
cfo Sod Repairs
270 Avro Rd (Maple)
Restoration Coder: Mr. Vivelc Patel 282.60 28260
Attn: Mr. Matt Lomano (W03? 23713545)
cfo Sod Repairs (Removal of Spoilszopsoil/Seeding)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}