# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Attn:)(.*)(\d{8})"
test_str = ("Restoration Coder: Mr. Vivek Patel 488.90 488.90\n"
"Attn: Mr. Matt Lomano (WO# 24107788)\n"
"0le Asphalt Repairs (Traffic ControltRemoval ofSpoilsfiSawcutting)\n"
"80 W est. Beaver Creek (Richmond Hill)\n"
"Restoration Coder: Mr. Vivek Patel 196.76 196.76\n"
"Attn: Mr. Matt. Lomano (WO# 23407489)\n"
"cfo Sod Repairs\n"
"270 Avro Rd (Maple)\n"
"Restoration Coder: Mr. Vivelc Patel 282.60 28260\n"
"Attn: Mr. Matt Lomano (W03? 23713545)\n"
"cfo Sod Repairs (Removal of Spoilszopsoil/Seeding)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.