import Foundation
let pattern = #"(?<=Attn:)(.*)(\d{8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Restoration Coder: Mr. Vivek Patel 488.90 488.90
Attn: Mr. Matt Lomano (WO# 24107788)
0le Asphalt Repairs (Traffic ControltRemoval ofSpoilsfiSawcutting)
80 W est. Beaver Creek (Richmond Hill)
Restoration Coder: Mr. Vivek Patel 196.76 196.76
Attn: Mr. Matt. Lomano (WO# 23407489)
cfo Sod Repairs
270 Avro Rd (Maple)
Restoration Coder: Mr. Vivelc Patel 282.60 28260
Attn: Mr. Matt Lomano (W03? 23713545)
cfo Sod Repairs (Removal of Spoilszopsoil/Seeding)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)