package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^@]+)(@[^,]+)(.*)`)
var str = `Привет, снова вы с нами @Людмила Сатина[123], рады вас видеть!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}