re = /([^@]+)(@[^,]+)(.*)/m
str = 'Привет, снова вы с нами @Людмила Сатина[123], рады вас видеть!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end