$re = '/([^@]+)(@[^,]+)(.*)/m';
$str = 'Привет, снова вы с нами @Людмила Сатина[123], рады вас видеть!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);