using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+|\-|\*|[^\d]\/)";
string input = @"(3/10)+(1/2)*(1/3)+(1/25)/(3/100)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}