package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\+|\-|\*|[^\d]\/)`)
var str = `(3/10)+(1/2)*(1/3)+(1/25)/(3/100)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}