#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>6)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>6X)(?P<sep_2>/|=)(?P<seal_material>V|)(?P<surface_coating>J3|)(?P<pipe_port>/60|)(?P<special_version>SO40|SO55|SO60|SO150|)(?P<additional_details>(.|[0-9])*)$" & @CRLF & _
""
Local $sString = "Z2S6A1-6X/VSO60" & @CRLF & _
"Z2S6B1-6X/VSO60" & @CRLF & _
"Z2S6-1-6X/MT" & @CRLF & _
"Z2S6-1-6X=" & @CRLF & _
"Z2S6-2-6X=V" & @CRLF & _
"Z2S6-1-6X/" & @CRLF & _
"Z2S6-2-6X/" & @CRLF & _
"Z2S6-3-6X/" & @CRLF & _
"Z2S6A1-6X/" & @CRLF & _
"Z2S6A2-6X/" & @CRLF & _
"Z2S6A3-6X/" & @CRLF & _
"Z2S6B1-6X/" & @CRLF & _
"Z2S6B2-6X/" & @CRLF & _
"Z2S6B3-6X/" & @CRLF & _
"Z2S6-1-6X/V" & @CRLF & _
"Z2S6-2-6X/V" & @CRLF & _
"Z2S6-3-6X/V" & @CRLF & _
"Z2S6A1-6X/V" & @CRLF & _
"Z2S6A2-6X/V" & @CRLF & _
"Z2S6A3-6X/V" & @CRLF & _
"Z2S6B1-6X/V" & @CRLF & _
"Z2S6B2-6X/V" & @CRLF & _
"Z2S6B3-6X/V" & @CRLF & _
"Z2S6B1-6X/SO40" & @CRLF & _
"Z2S6A1-6X/SO40" & @CRLF & _
"Z2S6B1-6X/VSO40" & @CRLF & _
"Z2S6B3-6X/SO40" & @CRLF & _
"Z2S6A2-6X/SO40" & @CRLF & _
"Z2S6A1-6X/SO60" & @CRLF & _
"Z2S6A2-6X/SO60" & @CRLF & _
"Z2S6B3-6X/SO60" & @CRLF & _
"Z2S6B2-6X/SO60" & @CRLF & _
"Z2S6B1-6X/SO60" & @CRLF & _
"Z2S6A3-6X/SO40" & @CRLF & _
"Z2S6B2-6X/SO40" & @CRLF & _
"Z2S6A1-6X/SO55" & @CRLF & _
"Z2S6A1-6X/VSO40" & @CRLF & _
"Z2S6-2-6X/SO55" & @CRLF & _
"Z2S6B2-6X/SO55" & @CRLF & _
"Z2S6-1-6X/SO55" & @CRLF & _
"Z2S6-1-6X//62" & @CRLF & _
"Z2S6A3-6X/SO60" & @CRLF & _
"Z2S6A2-6X//62" & @CRLF & _
"Z2S6B1-6X/SO55" & @CRLF & _
"Z2S6-1-6X/V/62" & @CRLF & _
"Z2S6A2-6X/SO55" & @CRLF & _
"Z2S6-1-6X/VSO55" & @CRLF & _
"Z2S6-4-6X/" & @CRLF & _
"Z2S6A3-6X/VSO40" & @CRLF & _
"Z2S6-3-6X/SO55" & @CRLF & _
"Z2S6-1-6X/=TA" & @CRLF & _
"Z2S6-3-6X/=TA" & @CRLF & _
"Z2S6B1-6X//62" & @CRLF & _
"Z2S6A1-6X//62" & @CRLF & _
"Z2S6A1-6X/VSO55" & @CRLF & _
"Z2S6-4-6X/V" & @CRLF & _
"Z2S6A1-6X/V/62" & @CRLF & _
"Z2S6-1-6X/VSO150" & @CRLF & _
"Z2S6B1-6X/V/62" & @CRLF & _
"Z2S6-2-6X//62" & @CRLF & _
"Z2S6-2-6X/SO150" & @CRLF & _
"Z2S6-2-6X/V/62" & @CRLF & _
"Z2S6A3-6X/SO55" & @CRLF & _
"Z2S6-3-6X/SO150" & @CRLF & _
"Z2S6-1-6X/V/60" & @CRLF & _
"Z2S6A2-6X/SO150" & @CRLF & _
"Z2S6B2-6X/VSO60" & @CRLF & _
"Z2S6A2-6X/VSO60" & @CRLF & _
"Z2S6-1-6X/SO150" & @CRLF & _
"Z2S6B3-6X/SO55" & @CRLF & _
"Z2S6A2-6X/VSO150" & @CRLF & _
"Z2S6-1-6X=V/60" & @CRLF & _
"Z2S6A2-6X/VJ3" & @CRLF & _
"Z2S6B1-6X/VJ3" & @CRLF & _
"Z2S6-1-6X/VJ3" & @CRLF & _
"Z2S6-1-6X/J3" & @CRLF & _
"Z2S6-1-6X/V/60J3" & @CRLF & _
"Z2S6-2-6X/VJ3" & @CRLF & _
"Z2S6-2-6X/J3SO150" & @CRLF & _
"Z2S6B1-6X/SO150" & @CRLF & _
"Z2S6-2-6X/VSO150" & @CRLF & _
"Z2S6A3-6X/SO150" & @CRLF & _
"Z2S6A3-6X/J3SO55" & @CRLF & _
"Z2S6A4-6X/V" & @CRLF & _
"Z2S6A1-6X/J3" & @CRLF & _
"Z2S6-1-6X/J3SO55" & @CRLF & _
"Z2S6-2-6X/J3" & @CRLF & _
"Z2S6B1-6X/J3" & @CRLF & _
"Z2S6A2-6X/VSO40" & @CRLF & _
"Z2S6-3-6X/J3=TA" & @CRLF & _
"Z2S6-3-6X/V/60" & @CRLF & _
"Z2S6A4-6X/" & @CRLF & _
"Z2S6A1-6X/MTJ3" & @CRLF & _
"Z2S6B1-6X/V*ET-BHS" & @CRLF & _
"Z2S6A1MVPP-SA/50350BAR" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")