import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>6)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>6X)(?P<sep_2>/|=)(?P<seal_material>V|)(?P<surface_coating>J3|)(?P<pipe_port>/60|)(?P<special_version>SO40|SO55|SO60|SO150|)(?P<additional_details>(.|[0-9])*)$\n";
final String string = "Z2S6A1-6X/VSO60\n"
+ "Z2S6B1-6X/VSO60\n"
+ "Z2S6-1-6X/MT\n"
+ "Z2S6-1-6X=\n"
+ "Z2S6-2-6X=V\n"
+ "Z2S6-1-6X/\n"
+ "Z2S6-2-6X/\n"
+ "Z2S6-3-6X/\n"
+ "Z2S6A1-6X/\n"
+ "Z2S6A2-6X/\n"
+ "Z2S6A3-6X/\n"
+ "Z2S6B1-6X/\n"
+ "Z2S6B2-6X/\n"
+ "Z2S6B3-6X/\n"
+ "Z2S6-1-6X/V\n"
+ "Z2S6-2-6X/V\n"
+ "Z2S6-3-6X/V\n"
+ "Z2S6A1-6X/V\n"
+ "Z2S6A2-6X/V\n"
+ "Z2S6A3-6X/V\n"
+ "Z2S6B1-6X/V\n"
+ "Z2S6B2-6X/V\n"
+ "Z2S6B3-6X/V\n"
+ "Z2S6B1-6X/SO40\n"
+ "Z2S6A1-6X/SO40\n"
+ "Z2S6B1-6X/VSO40\n"
+ "Z2S6B3-6X/SO40\n"
+ "Z2S6A2-6X/SO40\n"
+ "Z2S6A1-6X/SO60\n"
+ "Z2S6A2-6X/SO60\n"
+ "Z2S6B3-6X/SO60\n"
+ "Z2S6B2-6X/SO60\n"
+ "Z2S6B1-6X/SO60\n"
+ "Z2S6A3-6X/SO40\n"
+ "Z2S6B2-6X/SO40\n"
+ "Z2S6A1-6X/SO55\n"
+ "Z2S6A1-6X/VSO40\n"
+ "Z2S6-2-6X/SO55\n"
+ "Z2S6B2-6X/SO55\n"
+ "Z2S6-1-6X/SO55\n"
+ "Z2S6-1-6X//62\n"
+ "Z2S6A3-6X/SO60\n"
+ "Z2S6A2-6X//62\n"
+ "Z2S6B1-6X/SO55\n"
+ "Z2S6-1-6X/V/62\n"
+ "Z2S6A2-6X/SO55\n"
+ "Z2S6-1-6X/VSO55\n"
+ "Z2S6-4-6X/\n"
+ "Z2S6A3-6X/VSO40\n"
+ "Z2S6-3-6X/SO55\n"
+ "Z2S6-1-6X/=TA\n"
+ "Z2S6-3-6X/=TA\n"
+ "Z2S6B1-6X//62\n"
+ "Z2S6A1-6X//62\n"
+ "Z2S6A1-6X/VSO55\n"
+ "Z2S6-4-6X/V\n"
+ "Z2S6A1-6X/V/62\n"
+ "Z2S6-1-6X/VSO150\n"
+ "Z2S6B1-6X/V/62\n"
+ "Z2S6-2-6X//62\n"
+ "Z2S6-2-6X/SO150\n"
+ "Z2S6-2-6X/V/62\n"
+ "Z2S6A3-6X/SO55\n"
+ "Z2S6-3-6X/SO150\n"
+ "Z2S6-1-6X/V/60\n"
+ "Z2S6A2-6X/SO150\n"
+ "Z2S6B2-6X/VSO60\n"
+ "Z2S6A2-6X/VSO60\n"
+ "Z2S6-1-6X/SO150\n"
+ "Z2S6B3-6X/SO55\n"
+ "Z2S6A2-6X/VSO150\n"
+ "Z2S6-1-6X=V/60\n"
+ "Z2S6A2-6X/VJ3\n"
+ "Z2S6B1-6X/VJ3\n"
+ "Z2S6-1-6X/VJ3\n"
+ "Z2S6-1-6X/J3\n"
+ "Z2S6-1-6X/V/60J3\n"
+ "Z2S6-2-6X/VJ3\n"
+ "Z2S6-2-6X/J3SO150\n"
+ "Z2S6B1-6X/SO150\n"
+ "Z2S6-2-6X/VSO150\n"
+ "Z2S6A3-6X/SO150\n"
+ "Z2S6A3-6X/J3SO55\n"
+ "Z2S6A4-6X/V\n"
+ "Z2S6A1-6X/J3\n"
+ "Z2S6-1-6X/J3SO55\n"
+ "Z2S6-2-6X/J3\n"
+ "Z2S6B1-6X/J3\n"
+ "Z2S6A2-6X/VSO40\n"
+ "Z2S6-3-6X/J3=TA\n"
+ "Z2S6-3-6X/V/60\n"
+ "Z2S6A4-6X/\n"
+ "Z2S6A1-6X/MTJ3\n"
+ "Z2S6B1-6X/V*ET-BHS\n"
+ "Z2S6A1MVPP-SA/50350BAR\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}