$re = '/^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>6)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>6X)(?P<sep_2>/|=)(?P<seal_material>V|)(?P<surface_coating>J3|)(?P<pipe_port>/60|)(?P<special_version>SO40|SO55|SO60|SO150|)(?P<additional_details>(.|[0-9])*)$
/m';
$str = 'Z2S6A1-6X/VSO60
Z2S6B1-6X/VSO60
Z2S6-1-6X/MT
Z2S6-1-6X=
Z2S6-2-6X=V
Z2S6-1-6X/
Z2S6-2-6X/
Z2S6-3-6X/
Z2S6A1-6X/
Z2S6A2-6X/
Z2S6A3-6X/
Z2S6B1-6X/
Z2S6B2-6X/
Z2S6B3-6X/
Z2S6-1-6X/V
Z2S6-2-6X/V
Z2S6-3-6X/V
Z2S6A1-6X/V
Z2S6A2-6X/V
Z2S6A3-6X/V
Z2S6B1-6X/V
Z2S6B2-6X/V
Z2S6B3-6X/V
Z2S6B1-6X/SO40
Z2S6A1-6X/SO40
Z2S6B1-6X/VSO40
Z2S6B3-6X/SO40
Z2S6A2-6X/SO40
Z2S6A1-6X/SO60
Z2S6A2-6X/SO60
Z2S6B3-6X/SO60
Z2S6B2-6X/SO60
Z2S6B1-6X/SO60
Z2S6A3-6X/SO40
Z2S6B2-6X/SO40
Z2S6A1-6X/SO55
Z2S6A1-6X/VSO40
Z2S6-2-6X/SO55
Z2S6B2-6X/SO55
Z2S6-1-6X/SO55
Z2S6-1-6X//62
Z2S6A3-6X/SO60
Z2S6A2-6X//62
Z2S6B1-6X/SO55
Z2S6-1-6X/V/62
Z2S6A2-6X/SO55
Z2S6-1-6X/VSO55
Z2S6-4-6X/
Z2S6A3-6X/VSO40
Z2S6-3-6X/SO55
Z2S6-1-6X/=TA
Z2S6-3-6X/=TA
Z2S6B1-6X//62
Z2S6A1-6X//62
Z2S6A1-6X/VSO55
Z2S6-4-6X/V
Z2S6A1-6X/V/62
Z2S6-1-6X/VSO150
Z2S6B1-6X/V/62
Z2S6-2-6X//62
Z2S6-2-6X/SO150
Z2S6-2-6X/V/62
Z2S6A3-6X/SO55
Z2S6-3-6X/SO150
Z2S6-1-6X/V/60
Z2S6A2-6X/SO150
Z2S6B2-6X/VSO60
Z2S6A2-6X/VSO60
Z2S6-1-6X/SO150
Z2S6B3-6X/SO55
Z2S6A2-6X/VSO150
Z2S6-1-6X=V/60
Z2S6A2-6X/VJ3
Z2S6B1-6X/VJ3
Z2S6-1-6X/VJ3
Z2S6-1-6X/J3
Z2S6-1-6X/V/60J3
Z2S6-2-6X/VJ3
Z2S6-2-6X/J3SO150
Z2S6B1-6X/SO150
Z2S6-2-6X/VSO150
Z2S6A3-6X/SO150
Z2S6A3-6X/J3SO55
Z2S6A4-6X/V
Z2S6A1-6X/J3
Z2S6-1-6X/J3SO55
Z2S6-2-6X/J3
Z2S6B1-6X/J3
Z2S6A2-6X/VSO40
Z2S6-3-6X/J3=TA
Z2S6-3-6X/V/60
Z2S6A4-6X/
Z2S6A1-6X/MTJ3
Z2S6B1-6X/V*ET-BHS
Z2S6A1MVPP-SA/50350BAR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);