using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*CXX_COMPILER__(\w+)_.+?((?:\/.+)+) \|\|.*";
string input = @"build test/testfoo/CMakeFiles/testfoo2.dir/testfoo2.cpp.o: CXX_COMPILER__testfoo2_Debug /home/juxeii/projects/gtest-cmake-example/test/testfoo/testfoo2.cpp || cmake_object_order_depends_target_testfoo2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}