const regex = /.*CXX_COMPILER__(\w+)_.+?((?:\/.+)+) \|\|.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*CXX_COMPILER__(\\w+)_.+?((?:\\\/.+)+) \\|\\|.*', 'g')
const str = `build test/testfoo/CMakeFiles/testfoo2.dir/testfoo2.cpp.o: CXX_COMPILER__testfoo2_Debug /home/juxeii/projects/gtest-cmake-example/test/testfoo/testfoo2.cpp || cmake_object_order_depends_target_testfoo2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}