re = /.*CXX_COMPILER__(\w+)_.+?((?:\/.+)+) \|\|.*/
str = 'build test/testfoo/CMakeFiles/testfoo2.dir/testfoo2.cpp.o: CXX_COMPILER__testfoo2_Debug /home/juxeii/projects/gtest-cmake-example/test/testfoo/testfoo2.cpp || cmake_object_order_depends_target_testfoo2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end