package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^name:\s*(\w+)`)
var str = `name: Kelo
family name: Lam
location: Asia
members: Kelo, Kiko, Jil
name: Miko
family name: Naiton
location: Japan
members: Miko,Kayati `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}