re = /^name:\s*(\w+)/m
str = 'name: Kelo
family name: Lam
location: Asia
members: Kelo, Kiko, Jil
name: Miko
family name: Naiton
location: Japan
members: Miko,Kayati '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end