import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^name:\\s*(\\w+)";
final String string = "name: Kelo\n"
+ "family name: Lam\n"
+ "location: Asia\n"
+ "members: Kelo, Kiko, Jil\n\n"
+ "name: Miko\n"
+ "family name: Naiton\n"
+ "location: Japan\n"
+ "members: Miko,Kayati ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}